Delayed Search Indexing & Content Visibility

Incident Report for Retail Zipline

Monitoring

Update: The fix has been deployed and Resource Library document indexing has been re-enabled. The indexing backlog is processing and search results will continue to reflect recent changes over the next few hours as the queue works through accumulated jobs.

We are actively monitoring ElasticSearch performance to confirm full stability. All platform functionality: publishing, communications, bundles, published tabs, and document creation remains fully operational. There has been no data loss.

We will post a final update once we have confirmed the incident is fully resolved.
Posted Apr 10, 2026 - 12:59 PDT

Update

Update: Our engineering team has identified a resolution and is in the process of validating and deploying it.

The fix targets the root cause of the attachment indexing degradation and will allow us to safely resume document indexing for Resource Library search. Since yesterday evening platform performance is healthy.

Once validated, we will re-enable indexing and work through the accumulated backlog. Customers should expect Resource Library search to gradually reflect recent changes over the following hours as the queue drains.

All other functionality: publishing, communications, bundles, published tabs, and document creation remains fully operational. There will be no data loss.

We will post a final update once indexing has been fully restored.
Posted Apr 10, 2026 - 10:02 PDT

Update

Update: We have identified the root cause of this issue and have a plan in place.

Publisher bundles, published tabs, and communications are no longer impacted, we have deployed a change that restores normal behavior for publishers.

Resource Library document search remains operational. However, as part of our stabilization work, indexing of new Resource Library Documents has been temporarily paused to preserve overall platform search stability. Existing documents remain searchable. Updates to document metadata may not immediately be reflected in search results but the documents are still searchable.

Our engineering team is dedicated to a targeting a fix for tomorrow that we believe will fully resolve the underlying issue and allow us to resume normal attachment indexing with no backfilling required. Again there is no data loss.

We will post an update tomorrow as that work progresses.
Posted Apr 09, 2026 - 17:19 PDT

Update

Update: We are actively deploying a fix that will resolve the publisher bundle and published tab visibility issues and improve search indexing performance.

Publishing, document creation, and all core platform functionality remain fully operational. There will be no data loss.

We will post another update once the fix is confirmed in production.
Posted Apr 09, 2026 - 15:20 PDT

Identified

We are aware of an issue affecting search indexing performance. Some customers may experience the following:

• Delays in newly published communications appearing in bundles or published tabs
• Search results that are temporarily out of date (e.g., archived content still appearing, or recently updated titles not yet reflected)

Important: Publishing, document creation, and all core platform functionality remain fully operational. This issue is limited to the speed at which search indexes reflect recent changes and the majority of users won't be impacted.

Our engineering team has identified the underlying cause and is actively deploying a short term fix to restore normal indexing performance and prioritizing and working towards a longer term fix. There will be no data loss.

We will post another update within 60 minutes or sooner as the situation progresses.
Posted Apr 09, 2026 - 14:11 PDT

Update

We are continuing to investigate this issue.
Posted Apr 09, 2026 - 14:09 PDT

Investigating

We are aware of an issue affecting search indexing performance. Some customers may experience the following:

• Delays in newly published communications appearing in bundles or published tabs
• Search results that are temporarily out of date (e.g., archived content still appearing, or recently updated titles not yet reflected)

Important: Publishing, document creation, and all core platform functionality remain fully operational. This issue is limited to the speed at which search indexes reflect recent changes and the majority of users won't be impacted.

Our engineering team has identified the underlying cause and is actively deploying a short term fix to restore normal indexing performance and prioritizing and working towards a longer term fix. There will be no data loss.

We will post another update within 60 minutes or sooner as the situation progresses.
Posted Apr 09, 2026 - 13:58 PDT
This incident affects: Zipline Application (Search, Publishing).